XRP Withdrawals under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 14, 2019 - 00:24 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 13, 2019 - 22:52 UTC
This incident affected: Crypto Withdrawals (XRP).