CEX.IO service maintenance

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 18:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2025 - 16:57 UTC

Investigating

We are currently investigating this issue.
Posted Mar 14, 2025 - 16:41 UTC
This incident affected: Uptime (Website availability).