Crypto deposits are currently under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 08:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 16, 2020 - 08:22 UTC
This incident affected: Crypto Deposits (ETH, XRP, XLM, MHC, TRX, ONT, ONG, OMG, ADA, NEO, ATOM).