ATOM withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted May 06, 2021 - 11:27 UTC
Investigating
We are currently investigating this issue.
Posted May 06, 2021 - 08:19 UTC
This incident affected: Crypto Withdrawals (ATOM).