CEX.IO.BROKER under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 8 days ago. Jul 10, 2019 - 19:38 UTC
Update
We are continuing to work on a fix for this issue.
Posted 8 days ago. Jul 10, 2019 - 17:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 8 days ago. Jul 10, 2019 - 17:40 UTC
This incident affected: CEX.IO BROKER (Trading terminal, Deposits, Withdrawals, Account management).