CEX.IO BROKER is under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 23:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 26, 2021 - 22:45 UTC
This incident affected: CEX.IO BROKER (Trading terminal, Account management, Deposits, Withdrawals).