CEX.IO Broker Under Maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 08, 2019 - 09:39 UTC
Update
We are continuing to investigate this issue.
Posted Nov 08, 2019 - 09:19 UTC
Update
We are continuing to investigate this issue.
Posted Nov 08, 2019 - 09:18 UTC
Investigating
We are currently investigating this issue.
Posted Nov 08, 2019 - 09:15 UTC
This incident affected: CEX.IO BROKER (Trading terminal, Account management, Deposits, Withdrawals).