ETH Deposits and Withdrawals unstable
Incident Report for CEX.IO
Resolved
Issue re-solved
Posted Oct 30, 2018 - 11:38 UTC
Investigating
We are currently investigating this issue.
Posted Oct 29, 2018 - 20:13 UTC
This incident affected: Crypto Deposits (LTC, ETH).