XLM deposits/withdrawals under maintenance.
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 11:08 UTC
Investigating
We are currently investigating this issue.
Posted Oct 29, 2019 - 12:07 UTC
This incident affected: Crypto Withdrawals (XLM) and Crypto Deposits (XLM).