MHC transactions on maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 02, 2019 - 08:56 UTC
Investigating
We are currently investigating this issue.
Posted 4 months ago. Jul 02, 2019 - 08:30 UTC
This incident affected: Crypto Withdrawals (MHC) and Crypto Deposits (MHC).