MHC, TRX, ONT, ONG, ADA Under Maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 09, 2020 - 11:52 UTC
Identified
ETA - 1 hour
Posted Jan 09, 2020 - 11:19 UTC
This incident affected: Crypto Withdrawals (MHC, TRX, ONT, ONG, ADA) and Crypto Deposits (MHC, TRX, ONT, ONG, ADA).