Mobile app under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 8 days ago. Jul 11, 2019 - 11:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 8 days ago. Jul 11, 2019 - 04:52 UTC