RENBTC transactions maintenance
Incident Report for CEX.IO
Update
We are continuing to investigate this issue.
Posted Jan 11, 2024 - 15:27 UTC
Investigating
We are currently investigating this issue.
Posted Jan 12, 2023 - 13:15 UTC
This incident affects: Crypto Deposits (RENBTC) and Crypto Withdrawals (RENBTC).