CEX.IO Card Maintenance

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 19:23 UTC

Update

We are continuing to investigate this issue.
Posted Mar 24, 2025 - 16:33 UTC

Investigating

All card-related operations are temporarily unavailable. We'll be back soon!
Posted Mar 24, 2025 - 16:32 UTC
This incident affected: CEX.IO Card (Card transactions, Card ordering).