CEX.IO Deposits under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 8 days ago. Jul 10, 2019 - 20:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 8 days ago. Jul 10, 2019 - 17:22 UTC
This incident affected: Crypto Deposits (BTC, LTC, ETH, XRP, XLM, BCH, MHC, ZEC, BTG) and Fiat (Card Deposits, International Bank Transfer (Deposit), Domestic Bank Transfer (Deposit)).