Crypto transactions are unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 04, 2018 - 10:13 UTC
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Dec 04, 2018 - 08:49 UTC
This incident affected: Crypto Withdrawals and Crypto Deposits.