CEX.IO BROKER Under Maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Dec 26, 2019 - 11:39 UTC
Investigating
We are currently investigating this issue.
Posted Dec 26, 2019 - 11:12 UTC
This incident affected: CEX.IO BROKER (Trading terminal, Account management, Deposits, Withdrawals).