CEX.IO under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 11, 2019 - 11:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. Jul 11, 2019 - 06:19 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jul 11, 2019 - 04:45 UTC
This incident affected: Fiat (Card Deposits, Card Withdrawals, International Bank Transfer (Deposit), International Bank Transfer (Withdrawal), Domestic Bank Transfer (Deposit), Domestic Bank Transfer (Withdrawal)) and Uptime (Login).