ETH transactions under maintenance. CEX.IO
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 13 days ago. Jul 05, 2019 - 13:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 13 days ago. Jul 05, 2019 - 13:05 UTC
This incident affected: Crypto Withdrawals (ETH) and Crypto Deposits (ETH).