Skrill and Epay withdrawals maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Dec 03, 2024 - 10:00 UTC
Investigating
We are currently investigating this issue.
Posted Dec 02, 2024 - 13:51 UTC
This incident affected: Fiat (Skrill withdrawals, Epay withdrawals).