USD WIRE Deposits & Withdrawals are unavailable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 4 months ago. Dec 05, 2018 - 13:39 UTC
Investigating
We are currently investigating this issue.
Posted 4 months ago. Nov 15, 2018 - 14:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Nov 15, 2018 - 14:48 UTC
This incident affected: Bank deposits and Bank Withdrawal USD.