CEX.IO BROKER under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 11, 2019 - 17:28 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jul 11, 2019 - 04:39 UTC
This incident affected: CEX.IO BROKER (Trading terminal, Account management, Deposits, Withdrawals).