SEPA instant transfers maintenance

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 09:28 UTC

Identified

Due to an unexpected issue on our provider’s side, you may experience interruptions with the SEPA Instant payment method.

We will update you as soon as the system is operational again.
Posted Oct 06, 2025 - 12:15 UTC
This incident affected: Fiat (International Bank Transfer (Deposit), International Bank Transfer (Withdrawal)).