ZIL transactions maintenance

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Oct 02, 2024 - 11:17 UTC

Investigating

We are currently investigating this issue.
Posted Oct 01, 2024 - 17:47 UTC
This incident affected: Crypto Withdrawals (ZIL) and Crypto Deposits (ZIL).