CEX.IO under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 11, 2019 - 00:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jul 10, 2019 - 23:17 UTC
This incident affected: Uptime (Registrations, Login, Website availability, Trade Page, Buy/Sell page).