BSC transaction maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 26, 2023 - 10:51 UTC
Investigating
We are currently investigating this issue.
Posted Jun 01, 2023 - 16:39 UTC
This incident affected: Crypto Deposits (BEP-20 tokens) and Crypto Withdrawals (BEP-20 tokens).