QIWI deposits are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 02, 2021 - 05:58 UTC
Investigating
We are currently investigating this issue.
Posted May 15, 2021 - 15:24 UTC
This incident affected: Fiat (QIWI).