Anticipate maintenance downtime. Giving you heads up. Ahead of the US office launch, we will be performing a new release on our platform.
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 04, 2019 - 22:31 UTC
Monitoring
A fix has been implemented and we are checking the results. Maintenance should be finished in 30 minutes.
Posted 4 months ago. Jul 04, 2019 - 21:57 UTC
Update
We are expecting maintenance to be completed in 2 hours.
Posted 4 months ago. Jul 04, 2019 - 19:06 UTC
Update
We will keep you posted about timing and duration when this info becomes available!

Products affected: CEX.IO and CEX.IO BROKER.
Posted 4 months ago. Jul 04, 2019 - 12:46 UTC
Identified
We will keep you posted about timing and duration when this info becomes available!
Posted 4 months ago. Jul 04, 2019 - 12:26 UTC
This incident affected: CEX.IO BROKER (Trading terminal, Account management) and Uptime (Website availability).