BTC Deposits Unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 6 months ago. Dec 07, 2018 - 11:27 UTC
Investigating
We are currently investigating this issue.
Posted 6 months ago. Dec 07, 2018 - 09:34 UTC
This incident affected: Crypto Deposits (ETH).