Crypto deposits and withdrawals under maintenance
Incident Report for CEX.IO
Resolved
Issue is now re-solved.
Posted 7 months ago. Dec 03, 2018 - 11:05 UTC
Investigating
We are currently investigating this issue.
Posted 7 months ago. Dec 02, 2018 - 12:39 UTC
This incident affected: Crypto Deposits (LTC, ETH).