LINK withdrawals are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 15:50 UTC
Investigating
We are currently investigating this issue.
Posted Jan 26, 2021 - 08:45 UTC
This incident affected: Crypto Withdrawals (Chain Link (LINK)).