CEX.IO Card Maintenance

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 12:53 UTC

Update

We are continuing to investigate this issue.
Posted Nov 20, 2025 - 12:52 UTC

Investigating

Some card transactions may currently fail due to service disruptions. The relevant team is working to resolve the issue as quickly as possible. Thank you for your understanding!
Posted Nov 20, 2025 - 12:04 UTC
This incident affected: CEX.IO Card (Card transactions, Card ordering).