Card transactions maintenance

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted 6 months ago. Dec 05, 2024 - 18:40 UTC

Investigating

We are currently investigating this issue.
Posted 6 months ago. Dec 05, 2024 - 17:45 UTC
This incident affected: Fiat (Card Deposits, Card Withdrawals).