CEX.IO and CEX.IO Broker Login under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Oct 04, 2019 - 15:57 UTC
Update
We are continuing to investigate this issue.
Posted Oct 04, 2019 - 15:37 UTC
Investigating
We are currently investigating this issue.
Posted Oct 04, 2019 - 15:25 UTC
This incident affected: 2-Factor Authentication (Phone Call, SMS), Uptime (Login), and CEX.IO BROKER (Account management).