BTT Deposits unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 11, 2019 - 04:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jul 10, 2019 - 22:02 UTC
This incident affected: Crypto Deposits (BTT).