EUR Card withdrawals unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 16, 2018 - 07:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 13, 2018 - 04:34 UTC
This incident affected: Fiat (Domestic Bank Transfer (Deposit), Domestic Bank Transfer (Withdrawal)).