RUNE transactions maintenance

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 08:28 UTC

Investigating

We are currently investigating this issue.
Posted Jun 09, 2026 - 09:35 UTC
This incident affected: Crypto Deposits (RUNE (Thorchain)) and Crypto Withdrawals (RUNE (Thorchain)).