Service Performance May Vary Due to Increased Load

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Oct 11, 2025 - 07:30 UTC

Identified

We’re currently experiencing temporary service difficulties. Our team is working to resolve the issue as quickly as possible. Thank you for your patience.
Posted Oct 10, 2025 - 22:05 UTC
This incident affected: CEX.IO Spot Trading (Trading) and CEX.IO Margin Trading (Trading).