CEX.IO transactions processing maintenance

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Jan 20, 2025 - 13:50 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 20, 2025 - 13:01 UTC
This incident affected: Uptime (All fiat and crypto transactions).