CEX.IO Broker is currently under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 09:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 14, 2020 - 09:12 UTC
This incident affected: CEX.IO BROKER (Trading terminal, Account management, Deposits, Withdrawals).