BCH transactions under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 09, 2019 - 08:58 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 09, 2019 - 06:07 UTC
This incident affected: Crypto Deposits (BCH) and Crypto Withdrawals (BCH).