Cloudflare provided the following update: "Cloudflare services are currently operating normally. We are no longer observing elevated errors or latency across the network.
Our engineering teams continue to closely monitor the platform and perform a deeper investigation into the earlier disruption, but no configuration changes are being made at this time.
We will provide a final update once our investigation is complete."
Posted Nov 18, 2025 - 18:01 UTC
Monitoring
Cloudflare has implemented a fix for the network issues. The primary incident is believed to be resolved.
We are now actively monitoring our services closely to confirm full stability. Users may experience brief disruptions as the global network fully returns to normal.
Posted Nov 18, 2025 - 15:28 UTC
Update
Cloudflare Global Network is experiencing issues. We are monitoring their status and expect service to return to normal as soon as their network is fully restored.
Posted Nov 18, 2025 - 13:16 UTC
Update
We are observing an issue on Cloudflare’s side
Posted Nov 18, 2025 - 11:49 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 11:44 UTC
This incident affected: Uptime (Registrations, Help Center, Login, Website availability, Email Delivery, Customer Support, Spot and Margin Trading, Instant Buy/Sell, Verification, Affiliate program, CEX University, Earn, CEX.IO Card, All fiat and crypto transactions, Crypto deposits, Crypto withdrawals).