XLM deposits/withdrawals under maintenance.
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 01, 2019 - 10:18 UTC
Investigating
We are currently investigating this issue.
Posted Oct 31, 2019 - 08:55 UTC
This incident affected: Crypto Withdrawals (XLM) and Crypto Deposits (XLM).