Solana (SOL) network withdrawals are under maintenance

Incident Report for CEX.IO

Resolved

This incident has been resolved.
Posted Apr 13, 2025 - 05:56 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 11, 2025 - 13:46 UTC
This incident affected: Crypto Withdrawals (Solana (SOL) network).