CEX.IO under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 02, 2019 - 14:11 UTC
Investigating
We are currently investigating this issue.
Posted 4 months ago. Jul 02, 2019 - 13:50 UTC
This incident affected: Uptime (Website availability).