Help chat via Mobile app maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Sep 12, 2022 - 11:30 UTC
Investigating
We are currently investigating this issue.
Posted Feb 05, 2022 - 11:51 UTC
This incident affected: Uptime (Help Center).