XTZ withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 11:05 UTC
Investigating
We are currently investigating this issue.
Posted Sep 13, 2021 - 19:16 UTC
This incident affected: Crypto Withdrawals (XTZ).