MATIC operation's maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 16:27 UTC
Investigating
Token under migration to POL
Posted Sep 02, 2024 - 10:28 UTC
This incident affected: Crypto Withdrawals (MATIC) and Crypto Deposits (MATIC).