BTG transactions are currently under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 12, 2020 - 08:14 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 12, 2020 - 06:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 12, 2020 - 06:09 UTC
This incident affected: Crypto Deposits (BTG) and Crypto Withdrawals (BTG).