BCH withdrawals are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 10:17 UTC
Update
We are continuing to investigate this issue.
Posted Dec 29, 2020 - 16:54 UTC
Update
We are continuing to investigate this issue.
Posted Dec 25, 2020 - 10:40 UTC
Update
We are continuing to investigate this issue.
Posted Dec 16, 2020 - 18:44 UTC
Investigating
We are currently investigating this issue.
Posted Nov 15, 2020 - 11:04 UTC
This incident affected: Crypto Withdrawals (BCH).